hdu 1312Red and Black(DFS)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14254    Accepted Submission(s): 8832


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
   
   
   
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
   
   
   
   
45 59 6 13
 
题意:踩黑格子,最多可以踩多少黑格子

AC代码:

#include<iostream>
#include<cstring>
using namespace std;
char c[21][21];
int m,n;
int DFS(int x,int y){
	if(c[x][y]=='#'||x>=m||y>=n||x<0||y<0)
	return 0;
	else {
		c[x][y]='#';
		return 1+DFS(x-1,y)+DFS(x+1,y)+DFS(x,y+1)+DFS(x,y-1);
	}
} 
int main()
{
	int i,j,a,b;
	while(cin>>n>>m&&(m||n))
	{
		for(i=0;i<m;i++)
		{
			getchar();
			for(j=0;j<n;j++)
			{
				scanf("%c",&c[i][j]);
				if(c[i][j]=='@')
				{
					a=i;b=j;
				}
			}
		}
		 printf("%d\n",DFS(a,b));
	}
	return 0;
}


你可能感兴趣的:(hdu 1312Red and Black(DFS))