hdu1021 Fibonacci Again

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no
分析:f(n)能否被3整除.因为直接做的,数据会比较大,所以这里可以直接看余数。即f(0)=1,f(1)=2,f(3)=0,f(4)=2,f(5)=2,f(6)=1,f(7)=0,f(8)=1,f(9)=1,f(10)=2
从这儿就可以看出规律了!

#include<iostream>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
int a[]={1,2,0,2,2,1,0,1},n;
int main(){
    while(cin>>n)
    {
        int t=n%8;
        if(a[t]!=0)
        cout<<"no"<<endl;
        else
        cout<<"yes"<<endl; 
    }
    return 0;
} 

你可能感兴趣的:(hdu1021 Fibonacci Again)