HDU 1396 Counting Triangles

Counting Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2565    Accepted Submission(s): 1204


Problem Description
Given an equilateral triangle with n the length of its side, program to count how many triangles in it.

HDU 1396 Counting Triangles_第1张图片

 

Input
The length n (n <= 500) of the equilateral triangle's side, one per line.

process to the end of the file
 

Output
The number of triangles in the equilateral triangle, one per line.
 

Sample Input
   
   
   
   
1 2 3
 

Sample Output
   
   
   
   
1 5 13
 

Author
JIANG, Jiefeng
 

Source
ZOJ Monthly, June 2003
 

 

注意:

1:找规律

2:正三角形与倒的三角形的规律

#include<stdio.h>
int main (void)
{
    int f[505]= {0},n,a;
    f[1]=1;
    f[2]=5;
    f[3]=13;
    f[4]=27;
    f[5]=48;
    for(n=6; n<=500; n++)
    {
        if(n%2==0)
        {
            f[n]=f[n-1]+(2*n-1)+(n*n-n)/2+(n*n-4*n+4)/4;
        }//+(2*n-1)+(n*n-n)/2是正三角的增加规律
        //(n*n-4*n+4)/4是倒三角形的增加规律
        if(n%2==1)
        {
            f[n]=f[n-1]+(2*n-1)+(n*n-n)/2+(n*n-4*n+3)/4;
        }//(n*n-4*n+3)/4是n%2==1时倒三角的增加规律
    }
    while(~scanf("%d",&a))
    {
        printf("%d\n",f[a]);
    }
    return 0;
}

你可能感兴趣的:(ACM,HDU,hduoj)