HDOJ 1027Ignatius and the Princess II(全排列)

Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
   
   
   
   
6 4 11 8
 

Sample Output
   
   
   
   
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
 
//
//  main.cpp
//  1027
//
//  Created by 张嘉韬 on 16/2/9.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int main(int argc, const char * argv[]) {
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int a[10000];
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++) a[i]=i+1;
        int counter=1;
        while(counter!=m)
        {
            counter++;
            next_permutation(a+0,a+n);
        }
        for(int i=0;i<n;i++) {cout<<a[i];if(i!=n-1) cout<<" ";}
        cout<<endl;
    }
    return 0;
}

总结
本题中我们使用stl中的下一个排列的方法,需要注意的是next_permutation()的参数一个是需要排列的数组起始位置,另一个结束的位置+1

你可能感兴趣的:(HDOJ 1027Ignatius and the Princess II(全排列))