Lowest Bit

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9962    Accepted Submission(s): 7315


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
 

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
 

Output
For each A in the input, output a line containing only its lowest bit.
 

Sample Input
   
   
   
   
26 88 0
 

Sample Output
   
   
   
   
2 8
 
#include<iostream> 
using namespace std;
int lowbit(int x){
	return x&(-x);
}
int main()
{
	int T;
	while(cin>>T&&T)
	cout<<lowbit(T)<<endl;
}

树状数组中lowbit(int x)的应用O(∩_∩)O~,很简单哦

你可能感兴趣的:(Lowest Bit)