1058. A+B in Hogwarts (20)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:

14.1.28


IDEA

加法进位问题


CODE

#include<iostream>
#include<cstdio>
using namespace std;
struct Curr{
	int g;
	int s;
	int k;
}; 
int main(){
	Curr a,b;
	scanf("%d.%d.%d",&a.g,&a.s,&a.k);
	scanf("%d.%d.%d",&b.g,&b.s,&b.k);
	Curr result;
	int carry=0;
	result.k=(a.k+b.k)%29;
	carry=(a.k+b.k)/29;
	result.s=(carry+a.s+b.s)%17;
	carry=(carry+a.s+b.s)/17;
	result.g=carry+a.g+b.g;
/*	if(result.g>0){
		printf("%d.",result.g);
	}
*/
	printf("%d.%d.%d",result.g,result.s,result.k);

	
	return 0;
}


你可能感兴趣的:(pat,加法进位)