HDU 1114 Piggy-Bank (完全背包)

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9876    Accepted Submission(s): 4974


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
   
   
   
   
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
   
   
   
   
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 

一个完全背包的题目,题意就是告诉你一个储钱罐空时的重量,装满钱时的重量,以及各种硬币的面值和自身重量,问这时的罐内最少装了多少钱,如果没有合适的解则表示不可能达到这个重量。就是明显的完全背包,注意初试话就行了,初始化成一个大的值。

#include <cstdio>
#include <cstdlib>
#include <cstring>

const int MAX = 10002;
const int INT_MAX = 26000000;
int pack[MAX],all;

void init(int m){
	int i;

	for(i=1;i<=m;++i){
		pack[i]=INT_MAX;
	}
	pack[0] = 0;
}

void min(int &a,int b){
	if(a>b)a=b;
}

void cmPack(int cost,int value){
	int v;

	for(v=cost;v<=all;++v){
		min(pack[v],pack[v-cost]+value);
	}
}

int main(){

	//freopen("in.txt","r",stdin);
	int t,emp,full,n,p,w;

	scanf("%d",&t);
	while(t--){
		scanf("%d %d",&emp,&full);
		all = full - emp;
		init(all);
		scanf("%d",&n);
		while(n--){
			scanf("%d %d",&p,&w);
			cmPack(w,p);
		}

		if(pack[all]==INT_MAX){
			printf("This is impossible.\n");
		}else{
			printf("The minimum amount of money in the piggy-bank is %d.\n",pack[all]);
		}
	}
	return 0;
}


你可能感兴趣的:(动态规划,背包,完全背包)