Hduoj1004!【水题】

/*Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 73192    Accepted Submission(s): 27332

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most 
popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed.
 The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for
 each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 
Sample Output
red
pink
 
Author
WU, Jiazhi

Source
ZJCPC2004 
*/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct color
{
	char s[16];
	int num ;
} bal[1010];
int cmp(const void *a, const void *b)
{
	return (*(color *)b).num - (*(color*)a).num;
}

int main()
{
	int n, i , j;
	while(scanf("%d", &n) != EOF && n)
	{
		for(i = 0; i < n; i++)
		{
			scanf("%s", bal[i].s);
			bal[i].num = 1;
		}
		for(i = 0; i < n; i++)
		{
			if(bal[i].num == 0) continue;
			for( j = i+1; j < n; j++)
			if(strcmp(bal[i].s, bal[j].s ) == 0)
			{
				bal[i].num++;
				bal[j].num = 0;
			}
		}
		qsort(bal, n, sizeof(bal[0]), cmp);
		printf("%s\n", bal[0].s);
	}
	return 0;
}


题意:输入n串字符串,求出现次数最多的那个字符串。

思路:用结构体记录并统计字符串出现的次数,输出次数出现最多的那个字符串即可。

你可能感兴趣的:(Hduoj1004!【水题】)