hdu 4310 Hero

Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

Output
Output one line for each test, indicates the minimum HP loss.
 

Sample Input
   
   
   
   
1 10 2 2 100 1 1 100
 

Sample Output
   
   
   
   
20 201

这题首先分析一下;

设两个Hero分别为DPS1,HP1,DPS2,HP2,剩下所有的DPS之和为S;

先攻击英雄1(DPS1+DPS2+S)*HP1+(DPS2+S)*HP2;

先攻击英雄2(DPS1+DPS2+S)*HP2+(DPS1+S)*HP1;

不等式比较后,发现与HP1*DPS2和HP2*DPS1的大小有关;

只要进行排序即可;

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
struct Hero
{
    int DPS;
    int HP;
}hero[21];
bool cmp(const Hero &a,const Hero &b)
{
    return a.HP*b.DPS<a.DPS*b.HP;
}
int main()
{
    int N;
    while(scanf("%d",&N)!=EOF)
    {
        int sum=0;
        int zsum=0;
        for(int i=0;i<N;++i)
        {
            cin>>hero[i].DPS>>hero[i].HP;
            zsum+=hero[i].DPS;
        }
        sort(hero,hero+N,cmp);
        for(int i=0;i<N;++i)
        {
            sum+=zsum*hero[i].HP;
            zsum-=hero[i].DPS;
        }
        cout<<sum<<endl;
    }
    return 0;
}


你可能感兴趣的:(HDU)