hdu——1061Rightmost Digit(快速幂)

Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45812    Accepted Submission(s): 17250






Problem Description


Given a positive integer N, you should output the most right digit of N^N.




 




Input


The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).




Output


For each test case, you should output the rightmost digit of N^N.


Sample Input


2
3
4


Sample Output


7
6


Hint


In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.



Author


Ignatius.L


Recommend


快速幂直接求就好了  我有一篇快速幂的精简写法的博客可以看看

#include<iostream>
#include<string>
#include<cmath>
using namespace std;
long long kk(long long n)
{
	long long k=1,m=n;
	while(m!=0)
	{
		if(m&1)
		k*=n%10;
		m>>=1;
		n=n*n%10;
	}
	return k%10;
}
int main()
{
	long long n,m;
	cin>>n;
	while(n--)
	{
		cin>>m;
		cout<<kk(m)<<endl;
	}
	return 0;
}




你可能感兴趣的:(C++,HDU,乘方运算)