Lifting the Stone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6828 Accepted Submission(s): 2849
Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.
Output
Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.
Sample Input
2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11
Sample Output
求多边形重心问题,最后出现了精度问题。。。以后应该尽量少进行除法运算
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#define eps 1e-8
using namespace std;
double getS(int x1, int y1, int x2, int y2) {
double S = x1 * y2 - x2 * y1;
return S / 2;
}
int main() {
int T;
scanf("%d", &T);
while(T--) {
int N;
scanf("%d", &N);
int i;
int x1, y1, xx, yy, tx,ty;
scanf("%d %d", &x1, &y1);
tx = x1;
ty = y1;
double S;
double cenx, ceny;
double sumS = 0;
double sumcenxS = 0, sumcenyS = 0;
for(i = 1; i < N; i++) {
scanf("%d %d", &xx, &yy);
S = getS(tx, ty, xx, yy);
cenx = (tx + xx);
ceny = (ty + yy);
sumS += S;
sumcenxS += cenx * S;
sumcenyS += ceny * S;
tx = xx;
ty = yy;
}
S = getS(tx, ty, x1, y1);
cenx = (tx + x1);
ceny = (ty + y1);
sumS += S;
sumcenxS += cenx * S;
sumcenyS += ceny * S;
printf("%.2lf %.2lf\n", sumcenxS / (sumS * 3), sumcenyS / (sumS * 3));
}
return 0;
}