HDU 3555 Bomb(数位DP)

Description
求1~n中所有含49的数字的个数
Input
多组用例,每组一个整数n,以文件尾结束
Output
对于每组用例,输出1~n中含49的数的个数
Sample Input
3
1
50
500
Sample Output
0
1
15
Solution
数位DP,用dp[len][sure][state]表示当前位为len位,前面各位的状态sure(1表示出现过49,0表示未出现过49)且前一位状态为state(1表示前一位是4,0表示前一位不是4)时满足条件的数的个数
Code

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
typedef long long ll;
ll dp[25][2][2];
int num[25];
ll a;
ll dfs(int len,bool sure,bool state,bool fp)
{
    if(len<0)
        return sure?1:0;
    if(!fp&&dp[len][sure][state]!=-1)
        return dp[len][sure][state];
    ll ret=0;
    int fpmax=fp?num[len]:9;
    for(int i=0;i<=fpmax;i++)
        ret+=dfs(len-1,sure||state&&i==9,i==4,fp&&i==fpmax);
    if(!fp)
        dp[len][sure][state]=ret;
    return ret;
}
ll f(ll x)
{
    int len=0;
    while(x)
    {
        num[len++]=x%10;
        x/=10;
    }
    return dfs(len-1,0,0,true);
}
int main()
{
    int t;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        scanf("%lld",&a);
        printf("%lld\n",f(a));
    }
    return 0;
}

你可能感兴趣的:(HDU 3555 Bomb(数位DP))