POJ 1862- Stripies(优先队列)

M - Stripies
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 1862
Appoint description:  System Crawler  (2016-04-28)

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000
 
    
 
    
AC代码:
 
    
     
     
     
     
/*
这题目一直没看懂,都不知道说什莫,之后才知道
原来是从大到小取两个数,然后进行2*sqrt(m1*m2)
直到只剩下一个数就是答案了。
*/
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
#include<ctime>
#include<cstdlib>
#include<queue>
#include<vector>
#include<set>
using namespace std;
const int T=55000;
#define inf 0x3f3f3f3fL
typedef long long ll;


int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif

	int n,m,i;
	double j;
	while(~scanf("%d",&n))
	{
		priority_queue<double> q;
		for(i=0;i<n;++i){
			scanf("%lf",&j);
			q.push(j);
		}
		double u,v;
		while(q.size()>1)
		{
			u=q.top(),q.pop();
			v=q.top(),q.pop();
			j = 2*sqrt(u*v);
			q.push(j);
		}
		printf("%.3f\n",q.top());
	}
	return 0;
}


你可能感兴趣的:(poj,优先队列)