Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179
判断出是让写一个最小生成树程序,以下使用克鲁斯卡尔算分解决的
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct node{
int s,e,v;
}node;
node edge[10000];
int link[105]; //根节点
bool cmp(node a,node b)
{
return a.v<=b.v;
}
int find(int a) //算法核心,原理就是去找它自身根节点;
{
if (a!=link[a])
return find(link[a]); //能将包括a节点的连通子集遍历一遍
else
return a;
}
int fun(int n,int m)
{
sort(edge,edge+m,cmp);
int i,x,y,ans=0;
for (i=0;i<m;i++)
{
x=edge[i].e;
y=edge[i].s;
x=find(x);
y=find(y);
if (x!=y)
{
ans+=edge[i].v;
link[y]=x; //将前驱作为后继的根节点,并入集合中
}
}
return ans;
}
int main()
{
int i,j,n,m,t,k,a,b;
while (~scanf("%d",&n))
{
m=0;
for (i=1;i<=n;i++)
{
for (j=1;j<=n;j++)
{
scanf("%d",&k);
if (i>=j)
continue; //由于是对称的
edge[m].e=i;
edge[m].s=j;
edge[m].v=k;
m++;
}
}
for (i=1;i<=n;i++)
link[i]=i;
scanf("%d",&t);
for (i=1;i<=t;i++)
{
scanf("%d",&a);
scanf("%d",&b);
a=find(a);
b=find(b);
link[b]=a; //这是一个小集合
}
printf("%d\n",fun(n,m));
}
return 0;
}