Maximum Sum(Ural_1146)

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size 1 × 1 or greater located within the whole array.
As an example, the maximal sub-rectangle of the array:

0 −2 −7 0
9 2 −6 2
−4 1 −4 1
−1 8 0 −2

is in the lower-left-hand corner and has the sum of 15.

Input

The input consists of an N × N array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by N 2 integers separated by white-space (newlines and spaces). These N 2 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [−127, 127].

Output

The output is the sum of the maximal sub-rectangle.

Sample input

4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

Sample output

15

思路

把二维的矩阵压缩成一维的,再求最大连续子序列和就得出答案鸟~具体内容见代码注释~

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#define INF 0x3f3f3f3f

using namespace std;

int main()
{
    int n;
    int a[105][105];
    int pre[105];
    int s[105];
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < n; j++)
        {
            scanf("%d", &a[i][j]);
        }
    }
    int ans = a[0][0];
    for(int i = 0; i < n; i++) ///以i列为起始列求前缀和
    {
        memset(pre, 0, sizeof(pre));
        memset(s, 0, sizeof(s));
        for(int j = i; j < n; j++) ///求以i列为起始列的前j列和
        {
            for(int k = 0; k < n; k++) ///求出每一行以i列为起始列的前j列和
            {
                pre[k] += a[k][j];
            }
            s[0] = pre[0];
            for(int j = 1; j < n; j++)
            {
                s[j] = max(pre[j], s[j - 1] + pre[j]); ///s[j]存的是以第j个元素为子序列末端的最大连续和,动规思想,此处应该比较容易理解
                ans = max(ans, s[j]);
            }
        }
    }
    printf("%d\n", ans);
    return 0;
}

你可能感兴趣的:(Maximum Sum(Ural_1146))