[HDU]1.2.3 Balloon Comes!

纯水题,加减乘数。

起初没考虑商为整数的情况,两次WA,自责…


Problem:

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5094 Accepted Submission(s): 1641
 
Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
 
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.
 
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
 
Sample Input
4
+ 1 2
- 1 2
* 1 2
/ 1 2
 
Sample Output
3
-1
2
0.50
 
Author
lcy

Code:

#include<stdio.h>
int main()
{
    int T,a,b;
    char operation[2];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%d%d",operation,&a,&b);
        switch(operation[0])
        {
            case '+':
                printf("%d\n",a+b);
                break;
            case '-':
                printf("%d\n",a-b);
                break;
            case '*':
                printf("%d\n",a*b);
                break;
            case '/':
                if(a%b == 0)
                    printf("%d\n",a/b);
                else
                    printf("%.2lf\n",(double)a/b);
                break;
        }
    }
    return 0;
}

Tip

如果直接使用

char operation;
scanf("%c%d%d",operation,&a,&b);

operation会读取上一行末尾的'\n',进而出错。

我在这里使用了字符串输入解决

char operation[2];
scanf("%s%d%d",operation,&a,&b);


后来发现如下其他办法:

getchar();
scanf("%c %d %d",&c,&a,&b);


while(isspace((opnd=getchar()))); 


你可能感兴趣的:(输入问题)