POJ 3981 字符串替换

一、题目信息

字符串替换
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7501   Accepted: 3560

Description

编写一个C程序实现将字符串中的所有"you"替换成"we"

Input

输入包含多行数据 

每行数据是一个字符串,长度不超过1000 
数据以EOF结束

Output

对于输入的每一行,输出替换后的字符串

Sample Input

you are what you do

Sample Output

we are what we do

二、参考代码

#include <string> 
#include <iostream>
using namespace std;
int main()
{
    string str;
    while(getline(cin,str))
    {
        string::size_type pos = 0;
        while ( (pos = str.find("you", pos)) != string::npos ) {
            str.replace( pos++, 3, "we" );
        }
        cout << str << endl;
    }
    return 0;
}


你可能感兴趣的:(c,String,output)