hdoj-1496-Equations

Problem Description
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
   
   
   
   
1 2 3 -4 1 1 1 1
 

Sample Output
   
   
   
   
39088 0


和昨天做的一道hash的题目一模一样,做过一次后感觉这类题目很简单

详细思路就看poj-1840那个吧

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

short  ahash[2500001];

int main()
{
    int a,b,c,d;
    while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
    {
        if( (a>0 && b>0 && c>0 && d>0 )|| (a<0 && b<0 && c<0 && d<0) )
        {      printf("0\n");
               continue;
        }
         memset(ahash,0,sizeof(ahash));
        for(int i=-100;i<=100;i++)
        {
            if(i==0) continue;
            for(int j=-100;j<=100;j++)
            {
                if(j==0) continue;
                   int sum=(a*i*i+b*j*j)*(-1);
                 if(sum<0)
                    sum+=2500000;
                ahash[sum]++;
            }
        }
        int so=0;
        for(int i=-100;i<=100;i++)
        {
            if(i==0) continue;
            for(int j=-100;j<=100;j++)
            {
              if(j==0)  continue;
            int  sum=c*i*i+d*j*j;
                 if(sum<0)
                        sum+=2500000;
                    if(ahash[sum])
                        so+=ahash[sum];
            }
        }
        printf("%d\n",so);
    }
    return 0;;
}





你可能感兴趣的:(数据结构,哈希)