hdu 1068 Girls and Boys

Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.



Sample Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0


Sample Output
5
2
分析:这个题就是求最大独立集,用总结点数减去最大符合数
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int map[500][500],vis[500],link[500],n;        //数据要尽量放的大些
int fun(int i)
{
    int j;
    for (j=0;j<n;j++)
       if (map[i][j]&&!vis[j])
       {
           vis[j]=1;
           if (link[j]==-1||fun(link[j]))  //递归算的是看能否放弃这个,另找出其他符合条件的
           {
               link[j]=i;
               return 1;
           }
       }
    return 0;
}
int main()
{
    int i,j;
    while (scanf("%d",&n)==1)
    {
        int a,b,c;
        memset(map,0,sizeof(map));
        memset(link,-1,sizeof(link));
        for (i=0;i<n;i++)
        {

        scanf("%d: (%d)",&a,&b);
          for (j=0;j<b;j++)
            {
                scanf("%d",&c);
                map[a][c]=1;
            }
        }
        int count=0;
        for (i=0;i<n;i++)
        {
            memset(vis,0,sizeof(vis));
            if (fun(i))
               count++;
        }
        /*for (i=0;i<n;i++)
            printf(" %d",link[i]);    //这些就是对应的最后的最大符合情况
        printf("\n");*/
        printf("%d\n",n-count/2);
    }

    return 0;
}

你可能感兴趣的:(hdu 1068 Girls and Boys)