HDU 5375 Gray code

Problem Description
The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.

HDU 5375 Gray code_第1张图片

Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.
 

Input
The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)
 

Output
For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most
 

Sample Input
   
   
   
   
2 00?0 1 2 4 8 ???? 1 2 4 8
 

Sample Output
   
   
   
   
Case #1: 12 Case #2: 15
Hint
https://en.wikipedia.org/wiki/Gray_code http://baike.baidu.com/view/358724.htm
 


理解2进制转换格雷码的机制就好了,简单的dp一下

#include<cstdio>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=200005;
int T,n,a[maxn],f[maxn][2],tt=0;
char s[maxn];

int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%s",s+1);
        n=strlen(s+1);
        for (int i=1;i<=n;i++) scanf("%d",&a[i]);
        for (int i=1;s[i];i++) 
        {
            if (s[i]=='?') f[i][0]=f[i][1]=0;
            else 
            {
                f[i][s[i]-'0']=0;
                f[i]['1'-s[i]]=-1;
            }
        }
        f[0][0]=0;    f[0][1]=-1;
        for (int i=n-1;i>=0;i--)
        {
            if (f[i][0]>=0) 
            {
                if (f[i+1][0]>=0) f[i][0]=max(f[i][0],f[i+1][0]);
                if (f[i+1][1]>=0) f[i][0]=max(f[i][0],f[i+1][1]+a[i+1]);
            }
            if (f[i][1]>=0)
            {
                if (f[i+1][0]>=0) f[i][1]=max(f[i][1],f[i+1][0]+a[i+1]);
                if (f[i+1][1]>=0) f[i][1]=max(f[i][1],f[i+1][1]);
            }
        }
        printf("Case #%d: %d\n",++tt,f[0][0]);
    }
    return 0;
}


你可能感兴趣的:(HDU)