Charm Bracelet

Time Limit: 1000 MS      Memory Limit: 65536 KB      64bit IO Format: %I64d & %I64u
Submit  Status

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

数组开的太小了导致错误

#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
using namespace std;  
struct stu {  
    int val;  
    int cos;  
}boy[13010];  
int nexty[13010];
int main()  
{  
    int n,m;  
    int a,b;  
    while(scanf("%d%d",&n,&m)!=EOF) 
    {
        memset(boy,0,sizeof(boy));  
        memset(nexty,0,sizeof(nexty));  
        for(int i=0;i<n;i++)  
           scanf("%d%d",&boy[i].cos,&boy[i].val);  
        for(int i=0;i<n;i++)  
        {  
            for(int j=m;j>=boy[i].cos;j--)  
            nexty[j]=max(nexty[j],nexty[j-boy[i].cos]+boy[i].val);  
        }  
        printf("%d\n",nexty[m]);  
    }  
    return 0;  
}  



你可能感兴趣的:(Charm Bracelet)