HDU 1029 Ignatius and the Princess IV



Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output

For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input

     
     
     
     
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1

Sample Output

       
       
       
       
3 5 1       


第一次写以为是要次数出现最多的,后来还有个条件是要大于(n+1)/2;

加上后,用哈希存储就可以A了;

#include <bits/stdc++.h>
using namespace std ;
	int n , a,dp[999999+10];
int main()
{

	while(cin>>n)
	{
		memset(dp,0,sizeof(dp));
		int max ;
		for(int i = 0 ; i < n ; i++)
		{
			cin>>a;
			dp[a]++;
			if(dp[a]>=(n+1)/2)
			{
				max=a;
			}
		}
		cout<<max<<endl;
	}
	return 0 ;
}

你可能感兴趣的:(HDU 1029 Ignatius and the Princess IV)