Cube Stacking

 Cube Stacking
Time Limit:2000MS    Memory Limit:30000KB    64bit IO Format:%I64d & %I64u
Submit Status

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2


//用number 记录节点的总长度,place记录当前节点下面的节点长度,father用来递归寻找上一级
#include <cstdio>
using namespace std;
const int NMax=30030;
int N;
int father[NMax],number[NMax],place[NMax];
int find(int a)
{
    if(father[a]==-1) return a;
    int tmp=father[a];
    father[a]=find(father[a]);
    place[a]+=place[tmp];
    return father[a];
}
void Union(int a,int b)
{
    father[a]=b;
    place[a]+=number[b];
    number[b]+=number[a];
}
int main()
{
    int x,y,x1,y1;
    char buf[5];
    scanf("%d",&N);
    for(int i=1;i<=30000;i++)
    {
        place[i]=0;
        number[i]=1;
        father[i]=-1;
    }
    for(int I=1;I<=N;I++)
    {
        scanf("%s",buf);
        if(buf[0]=='M'){
            scanf("%d%d",&x,&y);
            x1=find(x);
            y1=find(y);
            if(x1!=y1)
                Union(x1,y1);
        }
        else{
            scanf("%d",&x);
            find(x);
            printf("%d\n",place[x]);
        }
    }
    return 0;
}

 

你可能感兴趣的:(Cube Stacking)