UVA - 264 - Count on Cantor (Cantor的数表!)

UVA - 264

Count on Cantor
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description


 Count on Cantor 

One of the famous proofs of modern mathematics is Georg Cantor's demonstration that the set of rational numbers is enumerable. The proof works by using an explicit enumeration of rational numbers as shown in the diagram below.

In the above diagram, the first term is 1/1, the second term is 1/2, the third term is 2/1, the fourth term is 3/1, the fifth term is 2/2, and so on.

Input and Output

You are to write a program that will read a list of numbers in the range from 1 to  and will print for each number the corresponding term in Cantor's enumeration as given below. No blank line should appear after the last number.

The input list contains a single number per line and will be terminated by end-of-file.

Sample input

3
14
7

Sample output

TERM 3 IS 2/1
TERM 14 IS 2/4
TERM 7 IS 1/4

有木有很熟悉的感觉,LRJ在UVA上做的第一个题,\(^o^)/~


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{
		printf("TERM %d IS ", n);
		int x = 1;
		while(n>(x*(x+1)/2))
		{
			x++;
		}
		n -= (x*(x-1)/2);
		if(x&1)
		{
			printf("%d/%d\n", (x+1)-n, n);
		}
		else
		{
			printf("%d/%d\n", n, (x+1)-n);
		}
	}
	return 0;
} 



你可能感兴趣的:(ACM,cantor,杂题,LRJ)