Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
3
1 1
10 2
10000 72
Sample Output
1
6
260
分析:求gcd(x,n)>=m的个数 。如果gcd(x,n)=m,那么x=q*m,n=p*m,p与q互素。求gcd(x,n)>=m,枚举n/m,即p,求p所有欧拉函数和。
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int lur(int nn)
{
int res=nn;
for(int i=2;i*i<=nn;i++)
{
if(nn%i==0)
{
res=res/i*(i-1);
nn/=i;
while(nn%i==0)
nn/=i;
}
}
if(nn>1)
res=res/nn*(nn-1);
return res;
}
int main()
{
int t,m,n;
cin>>t;
while(t--)
{
int sum=0;
cin>>n>>m;
if(m==1)
{
cout<<n<<endl;
continue;
}
for(int i=1;i*i<=n;i++)// 枚举m 我试着i [m,n]超时了,对于两个数相乘形式,枚举其中一个,这么做好像快些。
{
if(n%i==0)
{
if(i>=m)
sum+=lur(n/i);// n/i 即p
if(n/i!=i&&(n/i)>=m)
sum+=lur(i);
}
}
cout<<sum<<endl;
}
return 0;
}