杭电1159

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31638    Accepted Submission(s): 14334


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
   
   
   
   
abcfbc abfcab programming contest abcd mnp
 

Sample Output
   
   
   
   
4 2 0
 

Source
Southeastern Europe 2003
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:   1087  1176  1003  1058  1069 
#include <iostream>
#include <string>
using namespace std;
int main()
{
	string str1;
	string str2;
	int count;
	while(cin>>str1>>str2)
	{
	count=0;
   	int x_len = str1.length();
  	int y_len = str2.length();
  
  	int arr[500][500] = {{0,0}};
  
  	int i = 0;
  	int j = 0;
  
  	for(i = 1; i <= x_len; i++)
  	{
  		for(j = 1; j <= y_len; j++)
 		{
  			if(str1[i - 1] == str2[j - 1])
  			{
 				arr[i][j] = arr[i - 1][j - 1] + 1;
  			}
  			else
  			{
  		
 				if(arr[i][j - 1] >= arr[i - 1][j])
  				{
  					arr[i][j] = arr[i][j - 1];
  				}
  				else
  				{
  					arr[i][j] = arr[i -1][j];
  				}
  			}
  
  		}
  	}
    for(i = x_len, j = y_len; i >= 1 && j >= 1;)
     {
             if(str1[i - 1] == str2[j - 1])
             {
             	count++;
                 i--;
                 j--;
             }
             else
             {
                 if(arr[i][j -1] > arr[i - 1][j])
                 {
                     j--;
                 }
                 else
                 {
                     i--;
                 }
             }
     }
     cout<<count<<endl;
	 }
     return 0;
}

你可能感兴趣的:(杭电1159)