HDOJ 使用 容器类的 简单 题目

1 HDOJ 1029  http://acm.hdu.edu.cn/showproblem.php?pid=1029

题目:


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
   
   
   
   
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
   
   
   
   
3 5 1
 

代码:

#include <iostream>
#include <map>
#include <set>
#include <algorithm>

//默认的queue  和 queue  通过deque容器实现的  priority_queue 是在vector上实现的
using namespace std;
int main()
{
    int N,input;
    int s;
    while( cin >> N )
    {
        map< int, int > num;
        map< int, int >::iterator iter;
        s = N;
        while( N-- )
        {
            cin >> input;
            //如果不存在则为0,存在则加1
            ++num[input];
        }
        s = ( s + 1 ) >> 1;
        for( iter = num.begin(); iter != num.end(); iter++ )
        {
            if( iter -> second >= s )
            {
                cout << iter -> first;
                break;
            }
        }
        cout << endl;
    }
    return 0;
}




你可能感兴趣的:(HDOJ 使用 容器类的 简单 题目)