POJ 1328:Radar Installation:贪心法

Radar Installation
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 48200   Accepted: 10731

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
POJ 1328:Radar Installation:贪心法_第1张图片 
Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

Beijing 2002
根据雷达最大距离,每一个小岛都能有一个雷达安装范围,这样就得出n个线段,从而问题转化成求设置最少点,保证n个线段内都存在一个点。贪心法:
1,首先线段按左端点排序。,
2,第一个点先设置在第一条线段的右端点处,然后逐个处理后面的线段,保证线段里面有点的存在。
即如果这条线段的左端点在上一个雷达的右面,那么,需要重新设置一个雷达在这条线段的右端点;如果这条线段的左端点在上一个雷达的左面,并且线段的右端点也在雷达的左面,则调整雷达位置到这条线段的右面,才能保证雷达可以覆盖此线段。如果线段的右端点在雷达的右面,则不需要调整。
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
typedef struct node
{
	double x,y;
}island;
island a[1005];
int n,f,num,min;
double d;
void init()
{
	int i,j;
	double tx,ty;
	min=f=0;
	for(i=0;i<n;i++)
	{
		scanf("%lf%lf",&tx,&ty);
		if(ty>d)
			f=1;
		else
		{
			a[i].x=tx-sqrt(d*d-ty*ty);
			a[i].y=tx+sqrt(d*d-ty*ty);
		}
	}
}
int cmp(const void *a,const void *b)
{
	return (((island*)a)->x)<(((island*)b)->x)?-1:1;
}
void chuli()
{
	int i,j;
	double mark;
	mark=a[0].y;
	min=1;
	for(i=1;i<n;i++)
	{
		if(a[i].x<=mark)
		{
			if(a[i].y<mark)
				mark=a[i].y;
		}
		else
		{
			min++;
			mark=a[i].y;
		}
	}
}
int main()
{
	int i,j;
	num=1;
	while(scanf("%d%lf",&n,&d)!=EOF&&(n||d))
	{
		init();
		printf("Case %d: ",num++);
		if(f)
			printf("-1\n");
		else
		{
			qsort(a,n,sizeof(a[0]),cmp);
			chuli();
			printf("%d\n",min);
		}
	}
	return 0;
}


你可能感兴趣的:(POJ 1328:Radar Installation:贪心法)