HDOJ 1398 Square Coins

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10266    Accepted Submission(s): 7018


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
 

Sample Input
   
   
   
   
2 10 30 0
 

Sample Output
   
   
   
   
1 4 27
//
//  main.cpp
//  Square Coins
//
//  Created by 张嘉韬 on 16/1/27.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
using namespace std;
int main(int argc, const char * argv[]) {
    int n,c1[400],c2[400];
    while(scanf("%d",&n)&&n)
    {
        for(int i=0;i<=n;i++)
        {
            c1[i]=1;
            c2[i]=0;
        }
        for(int i=2;i<=17;i++)
        {
            for(int j=0;j<=n;j++)
            {
                for(int k=0;j+k<=n;k=k+i*i)
                {
                    c2[j+k]+=c1[j];
                }
            }
            for(int j=0;j<=n;j++)
            {
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        cout<<c1[n]<<endl;
    }
    return 0;
}

分析:
我们借助母函数的方法来解决组合问题,和数的拆分一样,很容易理解我们用系数来表示解决方法的数量,我们来理解一下这几个变量;
c1用来储存每一项的系数,如c[3]就是x^3的系数,很容易注意到我们c1数组的下标及表示是第几个数也表示是x的几次方,因为我们有(1+x+x^2+x^3.....)所以必定是这样。
首先我们初始化的时候让c1[i]=1;就是让各项的系数都预设成1,然后我们来计算,i表示是第几个数(硬币),j表示的是第i-1个数的第j个数,k表示是系数,我们这一段代码就是不断的合并各个数,
c2[j+k]+=c1[j];那么我们就不难理解这段代码,c2是用来保存当前合并后各项的系数,c2[j+k]就是x^(j+k)次,c1[j]就是j的系数,
 

你可能感兴趣的:(HDOJ 1398 Square Coins)