HDU-4788-Hard Disk Drive

Hard Disk Drive

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1358    Accepted Submission(s): 740


Problem Description
  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 

Input
  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 

Output
  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 

Sample Input
   
   
   
   
2 100[MB] 1[B]
 

Sample Output
   
   
   
   
Case #1: 4.63% Case #2: 0.00%
Hint
 

Source
2013 Asia Chengdu Regional Contest



今天醉了~,一个字母l打错,打成1了,晕死,还错了几遍,啊啊啊啊

水题,贴贴贴:



#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;

int main()
{
	int T, k=0;
	double a=1000.0/1024.0;
	scanf("%d", &T);
	while(T--)
	{
		k++;
		int b;
		char fun[5];
		scanf("%d[%s", &b, fun);
		printf("Case #%d: ", k);
		if(!strcmp(fun, "B]"))printf("0.00%%\n");
		else if(!strcmp(fun, "KB]"))printf("%.2lf%%\n", 100*(1.0- a));
		else if(!strcmp(fun, "MB]"))printf("%.2lf%%\n", 100*(1.0- a*a));
		else if(!strcmp(fun, "GB]"))printf("%.2lf%%\n", 100*(1.0- a*a*a));
		else if(!strcmp(fun, "TB]"))printf("%.2lf%%\n", 100*(1.0- a*a*a*a));
		else if(!strcmp(fun, "PB]"))printf("%.2lf%%\n", 100*(1.0- a*a*a*a*a));
		else if(!strcmp(fun, "EB]"))printf("%.2lf%%\n", 100*(1.0- a*a*a*a*a*a));
		else if(!strcmp(fun, "ZB]"))printf("%.2lf%%\n", 100*(1.0- a*a*a*a*a*a*a));
		else if(!strcmp(fun, "YB]"))printf("%.2lf%%\n", 100*(1.0- a*a*a*a*a*a*a*a));
	}
	return 0;
}


你可能感兴趣的:(C++,C语言,HDU,水题)