HDU1232

畅通工程
Time Limit: 2000msMemory Limit: 32768KB 64-bit integer IO format: %I64d Java class name: Main
Submit Status
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998

Hint
Hint

Huge input, scanf is recommended.

#include "iostream"
#include "cstring"
#include "cstdio"

using namespace std;

int town,path;
int pre[1005];



int find(int town)
{
    while(pre[town]!=town)
        town=pre[town];
    return town;
}


void join(int town1,int town2)
{
    int root1=find(town1);
    int root2=find(town2);
    if(root1!=root2)
        pre[root1]=root2;
}



int main()
{
    while(scanf("%d%d",&town,&path)!=EOF)
    {

        if(town==0)
            return 0;
        for(int i=1;i<=town;i++)
            pre[i]=i;

        for(int i=1;i<=path;i++)
        {
            int town1,town2;
            scanf("%d%d",&town1,&town2);
            join(town1,town2);

        }

        int count=0;
        for(int i=1;i<=town;i++)
            if(pre[i]==i)
                count++;
        printf("%d\n",count-1);
    }

}

你可能感兴趣的:(HDU1232)