poj2533DP最长上升序列

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 43875   Accepted: 19354

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4



动态规划:

dp[i]表示以xi结尾的序列最长子序列长度,有两种情况;

(1) =1(只有xi)

(2) =dp[j]+1(j<i,且xj<xi),这样就直接把xi放在末尾了


#include <cstdio>
#include <cstring> 
#include <algorithm>
#define maxn 1002
using namespace std;

int x[maxn],dp[maxn];
//dp[i],以xi结尾的最长子序列长度 
int main(){
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&x[i]);
	} 
	memset(dp,0,sizeof(dp));
	int m=0;
	for(int i=0;i<n;i++){
		dp[i]=1;
		for(int j=0;j<i;j++){
			if(x[j]<x[i]){
				dp[i]=max(dp[i],dp[j]+1);
			}			
		} 
		if(dp[i]>m) m=dp[i];
	}
	
	printf("%d",m);
	
	return 0;
}


另外一种方法:

dp[i]表示长度为i+1的上升子序列中末尾元素的最小值,不存在就是INF。













你可能感兴趣的:(poj2533DP最长上升序列)