CodeForces 621 B. Wet Shark and Bishops(水~)

Description
在一个1000*1000的图上有n个整点,如果两个点位于同一对角线上则会互相攻击,问互相攻击的点对数
Input
第一行为一整数n表示点数,之后n行每行两个整数xi,yi表示该点坐标(1<=n<=200000,1<=xi,yi<=1000)
Output
输出互相攻击的点对数
Sample Input
5
1 1
1 5
3 3
5 1
5 5
Sample Output
6
Solution
简单题,即统计每条满足x-y=a或者x+y=b的直线上的点数,因为a的范围是(-1000,1000),所以记录时可以将x-y的值加上1000使得a的范围变为(0,2000)
Code

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
#define maxn 222222
int n,x,y,res1[2*maxn],res2[2*maxn];
long long ans;
int main()
{
    while(~scanf("%d",&n))
    {
        memset(res1,0,sizeof(res1));
        memset(res2,0,sizeof(res2));
        ans=0;  
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            res1[x-y+1000]++;
            res2[x+y]++;
        }
        for(int i=0;i<=2000;i++)ans+=(res1[i]-1)*res1[i]/2;
        for(int i=0;i<=2000;i++)ans+=(res2[i]-1)*res2[i]/2;
        printf("%I64d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(CodeForces 621 B. Wet Shark and Bishops(水~))