poj 2552 第几个素数

Assistance Required
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2617   Accepted: 1519

Description

After the 1997/1998 Southwestern European Regional Contest (which was held in Ulm) a large contest party took place. The organization team invented a special mode of choosing those participants that were to assist with washing the dirty dishes. The contestants would line up in a queue, one behind the other. Each contestant got a number starting with 2 for the first one, 3 for the second one, 4 for the third one, and so on, consecutively.

The first contestant in the queue was asked for his number (which was 2). He was freed from the washing up and could party on, but every second contestant behind him had to go to the kitchen (those with numbers 4, 6, 8, etc). Then the next contestant in the remaining queue had to tell his number. He answered 3 and was freed from assisting, but every third contestant behind him was to help (those with numbers 9, 15, 21, etc). The next in the remaining queue had number 5 and was free, but every fifth contestant behind him was selected (those with numbers 19, 35, 49, etc). The next had number 7 and was free, but every seventh behind him had to assist, and so on.

Let us call the number of a contestant who does not need to assist with washing up a lucky number. Continuing the selection scheme, the lucky numbers are the ordered sequence 2, 3, 5, 7, 11, 13, 17, etc. Find out the lucky numbers to be prepared for the next contest party.

Input

The input contains several test cases. Each test case consists of an integer n. You may assume that 1<=n<=3000. A zero follows the input for the last test case.

Output

For each test case specified by n output on a single line the n-th lucky number.

Sample Input

1
2
10
20
0

Sample Output

2
3
29
83

 

//题目的要求很容易看出,同时我们做题也是会选择打表法

代码:

#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 34000
int prime[INF];
int main(){
	int n,sum;
	int i,j;
	for(i=0;i<INF;i++) prime[i]=1;
	prime[0]=0;
	prime[1]=0;
	i=2;
	while(i<INF){
		if(prime[i]==1){
			j=i+1;
			sum=0;

			while(j<INF){
				sum+=prime[j];
				if(sum==i){
					prime[j]=0;
					sum=0;
				}
				j++;
			}
		}
		i++;
	}
	while(cin>>n){
		if(n==0) break;
		i=2;
		sum=0;
		while(sum<n){
			if(prime[i]) sum++;i++;
		}
		if(sum==n)
			cout<<i-1<<endl;
	}
	return 0;
}


 

你可能感兴趣的:(poj 2552 第几个素数)