CSU1610: Binary Subtraction

Description

Zuosige always has bad luck. Recently, he is in hospital because of pneumonia. While he is taking his injection, he feels extremely bored. However, clever Zuosige comes up with a new game.

Zuosige writes two binary number on a paper, which are labelled as A and B. It is guaranteed that A is greater than B and A xor B = 2n+1-1 (n is the length of A), where xor means bitwise exclusive-or. Now he wants to know the value of A - B in binary.

Input

The first line contains one integer T, indicating the number of test cases.
In one test case, there are two lines.
In the first line, there are two integers n, m (0<=m < n/2, 1<=n<=1000000), indicating the length of the numbers and the number of 1s in B.
In the second line, there m integers indicating the positions where B is 1. Positions starting from 1, which is the lowest bit. It is guaranteed that A is greater than B.

Output

For each test case, output a line indicating the answer in binary without leading zero.

Sample Input

2
9 3
2 5 6
8 5
1 2 3 5 6

Sample Output

110011011
10010001

HINT

Source


题意:AB互异,知道B,求A

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
#define ls 2*i
#define rs 2*i+1
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,x) memset(a,x,sizeof(a))
#define w(a) while(a)
#define LL long long
const double pi = acos(-1.0);
#define N 1000005
#define mod 19999997
const int INF = 0x3f3f3f3f;
#define exp 1e-8

int a[N],b[N],ans[N];

int main()
{
    int t,n,m,i,j,k;
    cin >> t;
    w(t--)
    {
        cin>>n>>m;
        up(i,0,n)
        {
            b[i] = 0;
            a[i] = 1;
        }
        w(m--)
        {
            scanf("%d",&k);
            b[k] = 1;
            a[k] = 0;
        }
        int flag = 1;
        down(i,n-1,0)
        {
            if(a[i]==0&&flag) continue;
            printf("%d",a[i]);
            flag = 0;
        }
        printf("\n");
    }

    return 0;
}


你可能感兴趣的:(CSU)