POJ 2769 Reduced ID Numbers (同余)

Reduced ID Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9153   Accepted: 3675

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

题目大意:给G个学生的学号,求最小的m,使得每个学生的学号对m取余都不相等。
很明显,此题一定有解,范围[G,MAX_SIN],所以直接枚举就行,然后用is[] 数组判重。
#include <stdio.h>
#include <string.h>

const int maxn=1000000+10;

bool is[maxn];
int a[330];

int main()
{
	int T,n,i,m;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(m=n;;m++){
			for(i=0;i<m;i++) is[i]=0;
			for(i=0;i<n;i++){
				if(!is[a[i]%m]) is[a[i]%m]=1;
				else break;
			}
			if(i==n) break;
		}
		printf("%d\n",m);
	}
	return 0;
}


你可能感兴趣的:(poj)