Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 3310 |
|
Accepted: 1952 |
Description
After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.
Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.
Please help Bessie determine all of the barns that would be suitable to disconnect.
Input
* Line 1: A single integer, N. The barns are numbered 1..N.
* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.
Output
* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".
Sample Input
10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8
Sample Output
3
8
Hint
INPUT DETAILS:
The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles.
OUTPUT DETAILS:
If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).
这题就是,一个树,去掉一个结点,分成几个部分,如果这几个部分的最大结点数没有过n/2就把这个点输出来,明显的树状dp ,在这题中,我们可以
这样的看,我们把所有的子结点的数目保存下来,那么些结点的根上的最大值也可以快速保存起来,这样,找出最大值和n/2比较就可以了!
#include <iostream>
#include <vector>
#include <string.h>
#include <stdio.h>
#define MAXN 10005
using namespace std;
struct node {
int down,up;//分别记录子树的结点和,子树或根树的最大结点数
}queue[MAXN];
int visit[MAXN],n,head[MAXN],list[100*MAXN],e,next[100*MAXN];
int fmax(int a,int b)
{
if(a>b)
return a;
return b;
}
void addedge(int a,int b)
{
list[e]=b;
next[e]=head[a];
head[a]=e++;
list[e]=a;
next[e]=head[b];
head[b]=e++;
}
void dfs(int x)
{
visit[x]=1;
queue[x].down=1;//包含自已
queue[x].up=0;
int temp,i;
for(i=head[x];i!=-1;i=next[i])
{
temp=list[i];
if(!visit[temp])
{
dfs(temp);
queue[x].down+=queue[temp].down;
queue[x].up=fmax(queue[x].up,queue[temp].down);
}
}
queue[x].up=fmax(queue[x].up,n-queue[x].down);
}
int main()
{
int a,b,i,nn;
while(scanf("%d",&n)!=EOF)
{
e=0;
memset(list,-1,sizeof(list));
memset(visit,0,sizeof(visit));
memset(next,-1,sizeof(next));
memset(head,-1,sizeof(head));
for(i=1;i<n;i++)
{
scanf("%d%d",&a,&b);
addedge(a,b);
}
dfs(1);
bool flag=true;
for(i=1;i<=n;i++)
{
if(queue[i].up*2<=n)
{
printf("%d\n",i);
flag=false;
}
}
if(flag)
{
printf("NONE\n");
}
}
return 0;
}