HDU 5665 Lucky(思维题)【BC】

Problem Description
Chaos August likes to study the lucky numbers.

For a set of numbers S,we set the minimum non-negative integer,which can't be gotten by adding the number in S,as the lucky number.Of course,each number can be used many times.

Now, given a set of number S, you should answer whether S has a lucky number."NO" should be outputted only when it does have a lucky number.Otherwise,output "YES".

Input
The first line is a number T,which is case number.

In each case,the first line is a number n,which is the size of the number set.

Next are n numbers,means the number in the number set.

1≤n≤105,1≤T≤10,0≤ai≤109.

Output
Output“YES”or “NO”to every query.

Sample Input
1
1
2

Sample Output
NO

Source

BestCoder Round #80

本题是一道很水很水的题目,在这里给出AC代码:

#include<cstdio>

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int flag1=0,flag2=0;
        for(int i=0;i<n;i++)
        {
            int x;
            scanf("%d",&x);
            if(x==0)
            {
                flag1=1;
            }
            if(x==1)
            {
                flag2=1;
            }
        }
        if(flag1==1&&flag2==1)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}

你可能感兴趣的:(HDU)