Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
Source
Beijing 2002
代码
一开始贪心的方法想错了,后来的方法写的时候也是错误百出,目测是多年没刷题的后果233。我的思路是,如果两个点所形成的覆盖区域截取的x轴上的线段有重叠的话,那么这两个点一定能被同一个x轴上的点覆盖。就先计算出各点的覆盖圆在x轴上截取线段的左右坐标,按照左坐标从小到大排一下序,然后贪心就行了。
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
struct node
{
double L, R;
bool operator <(const node b)const
{
return L < b.L;
}
struct node &operator =(const node b)
{
L = b.L;
R = b.R;
return *this;
}
}a[1100];
int main()
{
int n, d;
double x, y;
int cnt = 0;
while(scanf("%d %d", &n, &d) && (n || d))
{
bool flag = 0;
cnt++;
for(int i = 0; i < n; i++)
{
scanf("%lf %lf", &x, &y);
if(y > d || y < -d)
flag = 1;
a[i].L = x - sqrt(d * d - y * y);
a[i].R = x + sqrt(d * d - y * y);
}
if(flag)
{
printf("Case %d: -1\n",cnt);
continue;
}
sort(a, a + n);
int ans = 1;
struct node k;
k = a[0];
for(int i = 1; i < n; i++)
{
if(a[i].R < k.R)
k = a[i];
else if(a[i].L > k.R)
{
ans++;
k = a[i];
}
}
printf("Case %d: %d\n", cnt, ans);
}
return 0;
}