poj 2533 Longest Ordered Subsequence 很水的最长递增序列

http://poj.org/problem?id=2533

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 24240   Accepted: 10531

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

题目很简单,用来练习最长**序列的题目,

第i为的最长增序列 等于第i-1到1 中比i小的所有递增序列中最长的+1;

#include <stdio.h>
int main()
{
	int n,i,j;
	int q[3001],up[3001];
	scanf("%d",&n);
		int m1=1,m;       //m1=1 当吃输入1的时候 长度为1  开始我定义为0 ,WA 了好多次...
	for(i=0;i<n;i++)
	{
		scanf("%d",&q[i]);
		up[i]=1;
	}
	for(i=1;i<n;i++)
    {
		m=0;
		for(j=i-1;j>=0;j--)
		{
			if(q[j]<q[i])
			{
				if(up[j]>m)
					m=up[j];
			}
		}
		 up[i]=m+1;
		if(up[i]>m1)
			m1=up[i];
	}
		printf("%d\n",m1);
	return 0;
}


你可能感兴趣的:(poj 2533 Longest Ordered Subsequence 很水的最长递增序列)