Friend

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2220    Accepted Submission(s): 1116


Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
   
   
   
   
3 13121 12131
 

Sample Output
   
   
   
   
YES! YES! NO!
  由题意知,需要判断x=?ab+a+b;经过变形x+1=(a+1)*(b+1);令x+1=s;所以s=(a+1)*(b+1);因为a=1;b=2,所以s=3*2;由此推广s^e=3^q*2^a;

#include<stdio.h>
int main()
{
    int n;
    while(scanf("%d",&n)!=-1)
    {
        if(n==0)
          {
                  printf("NO!\n");
                  continue;
          }
        
        n=n+1;
        while(n%2==0||n%3==0)
      {
        if(n%2==0)
                 n=n/2;
        else if(n%3==0)
                       n=n/3;
       }
    if(n==1)
    printf("YES!\n");
    else printf("NO!\n");
    }
    return 0;
}




你可能感兴趣的:(Friend)