hdu2795 Billboard

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8255    Accepted Submission(s): 3670


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
   
   
   
   
3 5 5 2 4 3 3 3
 

Sample Output
   
   
   
   
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
HDOJ 2009 Summer Exercise(5)
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1542  1828  1540  1255  2871 
 



刚开始想着,按照每一列的可用长度建线段树,然后维护一段的可用长度的最大值,然后每次要贴海报的时候二分查找到最靠前的海报,这样复杂度是O(nlognlogn)居然被卡掉了,后来发现尼玛脑残了,要找到最靠前的海报就只需要查询一次线段树就行了,从根节点往下走如果左子树的可用长度最大值满足就往左走否则往右走,然后……然后就这么过了……


代码


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

typedef struct
{
    int l,r,val;
}Tree;

Tree tree[1000000];
int m;

void Build(int t,int l,int r)
{
    tree[t].l=l;
    tree[t].r=r;
    tree[t].val=m;
    if (l==r) return;
    int mid=(l+r)/2;
    Build(2*t+1,l,mid);
    Build(2*t+2,mid+1,r);
}

void Find(int t,int val)
{
    if (tree[t].l==tree[t].r)
    {
        tree[t].val-=val;
        printf("%d\n",tree[t].l+1);
        return;
    }
    if (tree[2*t+1].val>=val) Find(2*t+1,val);
    else Find(2*t+2,val);
    tree[t].val=max(tree[2*t+1].val,tree[2*t+2].val);
}

int main()
{
    int i,j,n,x,T;
    while(scanf("%d%d%d",&n,&m,&T)!=EOF)
    {
        n=min(n,200000);
        Build(0,0,n-1);
        while(T--)
        {
            scanf("%d",&x);
            if (x>tree[0].val) printf("-1\n");
            else Find(0,x);
        }
    }
    return 0;
}




你可能感兴趣的:(hdu2795 Billboard)