Problem Description
Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).
Input
The first line contains the integer T indicating to the number of test cases.
For each test case, the first line contains the integers n and B.
Following n lines provide the information of each item.
The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.
1 <= number of test cases <= 100
1 <= n <= 500
1 <= B, w[i] <= 1000000000
1 <= v[1]+v[2]+...+v[n] <= 5000
All the inputs are integers.
Output
For each test case, output the maximum value.
Sample Input
1
5 15
12 4
2 2
1 1
4 10
1 2 Sample Output
15
这一题跟平时的背包其实是一样的, 就是背包的容量太大了,枚举背包会超时,改为枚举价值
AC代码:
# include <cstdio>
# include <iostream>
# include <algorithm>
using namespace std;
int dp[2][5010];
int w[510], v[510];
const int inf=2000000000;
int main(){
int n, i, j, k, e, sum_value, t, W;
cin>>t;
for(i=1; i<=t; i++){
cin>>n>>W;
sum_value=0;
for(j=1; j<=n; j++){
cin>>w[j]>>v[j];
sum_value=sum_value+v[j];
}
e=1;
for(j=0; j<=1; j++){
for(k=0; k<=5009; k++){
dp[j][k]=inf;
}
}
dp[0][0]=dp[1][0]=0;
for(j=1; j<=n; j++){
e=1-e;
for(k=1; k<=sum_value; k++){
dp[1-e][k]=dp[e][k];
if(k>=v[j])
dp[1-e][k]=min(dp[e][k], dp[e][k-v[j]]+w[j]);
}
}
for(j=sum_value; j>=0; j--){
if(dp[1-e][j]<=W){
cout<<j<<endl;
break;
}
}
}
return 0;
}