POJ 2192 Zipper

Zipper
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15938   Accepted: 5651

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: tcraete 

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: catrtee 

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. 

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive. 

Output

For each data set, print: 

Data set n: yes 

if the third string can be formed from the first two, or 

Data set n: no 

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example. 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int main()
{
	int n;
	scanf("%d", &n);
	int k;
	for(k=1;k<=n;k++)
	{
		bool flag=true;
		bool dp[205][205];
		memset(dp,0,sizeof(dp));
		char a[201],b[201],c[402];
		//cin>>a>>b>>c;
		scanf("%s %s %s", a, b, c);
	    //cout<<"Data set "<<c<<": ";
	    printf("Data set %d: ", k);
		int lena,lenb,lenstr;
		lena=strlen(a);
		lenb=strlen(b);
		int i,j;
		dp[0][0]=1;
		for(i=0;i<=lena;i++)
            for(j=0;j<=lenb;j++)
            {
                if(i>0&&dp[i-1][j]==1&&c[i+j-1]==a[i-1])
                    dp[i][j]=1;
                if(j>0&&dp[i][j-1]==1&&c[i+j-1]==b[j-1])
                    dp[i][j]=1;
            }
		if(dp[lena][lenb]==true)
			//cout<<"yes"<<endl;
			printf("yes\n");
		else
			//cout<<"no"<<endl;
			printf("no\n");
	}
    return 0;
}

/*
3
cat tree tcraete
cat tree catrtee
cat tree cttaree

*/


详细讲解 见 http://www.ahathinking.com/archives/173.html


你可能感兴趣的:(POJ 2192 Zipper)