HLG 1710 给出三个集合a,b,c,统计集合a元素+集合b中元素=集合c中的元素的个数 (基础题)

链接: http://acm.hrbust.edu.cn/index.php?m=ProblemSet&a=showProblem&problem_id=1710

Description
有A、 B、 C 三个集合的,其中a∈A, b ∈ B, c ∈ C,求有多少种方式使得a + b = c。

Input
有多组测试数据,请处理到文件结束。

对于每组测试数据,有三行:

第一行为A集合的描述,第一个数为n,表示A集合有n个数,接下来有n个整数a1~an。

第二行为B集合,第三行为C集合,表示含义参考第一行。

每个集合中的数两两不相等。

1<=n<=5000,|ai| <= 1 000 000 000


Output
对于每组测试数据,输出一行,包含一个整数,表示有多少种组合方式。

Sample Input
3 -10 4 -6
3 -10 3 -1
3 3 -4 -6
3 -8 -9 -4
3 9 -10 2
3 -8 -7 5
3 -4 -6 -2
3 9 -9 -2
3 3 -13 -4
Sample Output
2
2
3


代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <set>
#include <map>
#include <vector>
#include <algorithm>
#define MAXN 5005
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int a[MAXN], b[MAXN], c[MAXN];
int a_n, b_n, c_n, res;

int cmp(const void *a, const void *b)
{
    return *(int *)a - *(int *)b;
}

void Init()
{
    RST(a), RST(b), RST(c), res = 0;
    for(int i=0; i<a_n; i++) scanf("%d", &a[i]);
    scanf("%d", &b_n);
    for(int i=0; i<b_n; i++) scanf("%d", &b[i]);
    scanf("%d", &c_n);
    for(int i=0; i<c_n; i++) scanf("%d", &c[i]);
    qsort(a, a_n, sizeof(a[0]), cmp);
    qsort(b, b_n, sizeof(b[0]), cmp);
}

void solve()
{
    for(int i=0; i<c_n; ++i) {
        for(int j=0, k=b_n-1; j<a_n && k>=0; ) {
            if(a[j] + b[k]> c[i]) k--;
            else if(a[j] + b[k]< c[i]) j++;
            else j++, k--, res++; 
        }
    }
    printf("%d\n", res);
}

int main()
{
    while(~scanf("%d", &a_n)) {
        Init(), solve();
    }
    return 0;
}


你可能感兴趣的:(HLG 1710 给出三个集合a,b,c,统计集合a元素+集合b中元素=集合c中的元素的个数 (基础题))