Function Run Fun
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3358 Accepted Submission(s): 1652
Problem Description
We all love recursion! Don't we?
Consider a three-parameter recursive function w(a, b, c):
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1
if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)
if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
Output
Print the value for w(a,b,c) for each triple.
Sample Input
1 1 1 2 2 2 10 4 6 50 50 50 -1 7 18 -1 -1 -1
Sample Output
w(1, 1, 1) = 2 w(2, 2, 2) = 4 w(10, 4, 6) = 523 w(50, 50, 50) = 1048576 w(-1, 7, 18) = 1
分析:
用一个三维数组来存储一下递归调用的结果,每次用到该数据时直接返回值即可。题目没有给说数据a,b,c的大小,但根据题目中的判断,知道范围是【0,20】;
代码如下:
#include <stdio.h>
#include <string.h>
int dp[25][25][25];
int w(int a,int b,int c)
{
if(dp[a][b][c])
return dp[a][b][c];
if(a<=0 || b<=0 || c<=0)
{
dp[a][b][c]=1;
return 1;
}
else if(a>20 || b>20 || c>20)
{
dp[a][b][c]=w(20,20,20);
return dp[a][b][c];
}
else if(a<b && b<c)
{
dp[a][b][c]=w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c);
return dp[a][b][c];
}
else
{
dp[a][b][c]=w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1);
return dp[a][b][c];
}
}
int main()
{
int a,b,c;
int sum;
while(scanf("%d %d %d",&a,&b,&c),!(a==-1 && b==-1 && c==-1))
{
sum=0;
memset(dp,0,sizeof(dp));
if(a<=0 || b<=0 || c<=0)
sum=1;
else if(a>20 || b>20 || c>20)
sum=w(20,20,20);
else
sum=w(a,b,c);
printf("w(%d, %d, %d) = %d\n",a,b,c,sum);
}
return 0;
}