poj3468 A Simple Problem with Integers

A Simple Problem with Integers
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 31654   Accepted: 8984
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi


线段树,额,记得longlong就行了。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

typedef struct
{
    int l,r,lazy;
    long long num,tag;
}Tree;

Tree tree[500005];

void Build(int t,int l,int r)
{
    int mid;
    tree[t].l=l;
    tree[t].r=r;
    tree[t].tag=0;
    tree[t].lazy=1;
    if (l==r)
    {
        scanf("%lld",&tree[t].num);
        return;
    }
    mid=(l+r)/2;
    Build(2*t+1,l,mid);
    Build(2*t+2,mid+1,r);
    tree[t].num=tree[2*t+1].num+tree[2*t+2].num;
}

void Add(int t,int x,int y,long long z)
{
    int l,r,mid;
    l=tree[t].l;
    r=tree[t].r;
    if (x==l && y==r)
    {
        tree[t].lazy=1;
        tree[t].tag+=z;
        tree[t].num+=z*(r-l+1);
        return;
    }
    mid=(l+r)/2;
    if (tree[t].lazy==1)
    {
        tree[t].lazy=0;
        Add(2*t+1,l,mid,tree[t].tag);
        Add(2*t+2,mid+1,r,tree[t].tag);
        tree[t].tag=0;
    }
    if (x<=mid) Add(2*t+1,x,min(y,mid),z);
    if (y>mid) Add(2*t+2,max(x,mid+1),y,z);
    tree[t].num=tree[2*t+1].num+tree[2*t+2].num;
}

long long Find(int t,int x,int y)
{
    int mid,l,r;
    l=tree[t].l;
    r=tree[t].r;
    if (l==x && y==r)
    {
        return tree[t].num;
    }
    mid=(l+r)/2;
    if (tree[t].lazy==1)
    {
        tree[t].lazy=0;
        Add(2*t+1,l,mid,tree[t].tag);
        Add(2*t+2,mid+1,r,tree[t].tag);
        tree[t].tag=0;
    }
    long long ans=0;
    if (x<=mid) ans+=Find(2*t+1,x,min(mid,y));
    if (y>mid) ans+=Find(2*t+2,max(mid+1,x),y);
    return ans;
}

int main()
{
    int i,j,n,m,x,y;
    long long z;
    char str[20];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        Build(0,0,n-1);
        while(m--)
        {
            scanf("%s",str);
            if (str[0]=='Q')
            {
                scanf("%d%d",&x,&y);
                printf("%lld\n",Find(0,x-1,y-1));
            }
            else
            {
                scanf("%d%d%lld",&x,&y,&z);
                Add(0,x-1,y-1,z);
            }
        }
    }
    return 0;
}


你可能感兴趣的:(poj3468 A Simple Problem with Integers)