hdu3411 Snail Alice

Snail Alice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 371    Accepted Submission(s): 96


Problem Description
Snail Alice is a snail indulged in math. One day, when she was walking on the grass, suddenly an accident happened. Snail Alice fell into a bottomless hole, which was deep enough that she kept falling for a very long time. In the end, she caught the lateral wall of the hole and stop falling down. She named the place where she stopped “lucky place” immediately.

Snail Alice decided to climb up along the wall from the “lucky place”. The first day she climbed up q0 (q is a positive constant integer) metres, but at night when she fell asleep, she fell down q1 metres. She was shocked when she woke up, and she decided to make an extra effort. The second day she finally climbed up q2 metres. To her surprise, she fell down faster because of the tiredness. She fell down q3 metres at night. The longer she climbed up the longer she fell down. But finally, she still climbed out of the hole and slept on the ground.

Lying on the grass safe, she was curious about a question. How many metres was the “lucky place” down under the ground? She remembered that the sum of the times of her climbing up and falling down is n(of course, n is odd), so the distance between the ground and the “lucky place” must be 1-q+q2-q3+...+(-1)n-1qn-1. Snail Alice simplified that long formula and get a beautiful result: (qn+1)/(q+1). But as a math professor, she wouldn’t stop. She came up with a good problem to test her students. Here is the problem:

A function f(n), n is a positive integer, and


Given q and n, please calculate the value of f(n).Please note that q and n could be huge.
 

Input
Input consists of multiple test cases, and ends with a line of “-1 -1 -1”.
For each test case:
The first line contains three integers x1, y1 and z1, representing q. q=x1^y1+z1.
The second line contains two integers: y2 and z2, representing n. n=2^y2+z2.
The third line contains a single integer P, meaning that what you really should output is the formula’s value mod P.
Note: 0<=x1,y1,z1,y2,z2<=50000, z1>0, 0<P<100000000
 

Output
For each test case, print one line containing an integer which equals to the formula’s value mod P.
 

Sample Input
   
   
   
   
2 1 3 0 0 32551 3 0 5 0 2 70546 -1 -1 -1
 

Sample Output
   
   
   
   
1 31
 

Source
2010 National Programming Invitational Contest Host by ZSTU

话说,这题做了一天了,表示这个效率真糟糕……
好吧,切入主题,这题反正说白了就是求f(n),然后q=x1^y1+z1,n=2^y2+z2。所以q和n都很大。
其实推完式子很简单:F(n)=(q-1)F(n-1)+(q-2)F(n-2)。
具体过程如下:

之后,因为n是2^y2+z2,相当大,因此可以先减去1,得到2^y2-1+z2。根据矩阵快速幂,对于指数的二进制是1的,需要将底数和答案乘一次,如果二进制是0,则不需要。因此观察2^y2-1,所有位上都是1,因此只需要模拟一遍y2-1位的矩阵快速幂,最后加上z2即可。
下午超时超到疯掉,后来发现,把一些不必要的longlong改成int就可以过了。
代码如下
#include <stdio.h>

typedef struct
{
    long long M[2][2];
}Matrix;

Matrix a,b,c,aa;
long long p;

Matrix Mul(Matrix x,Matrix y)
{
    int i,j,k;
    for (i=0;i<2;i++)
    {
        for (j=0;j<2;j++)
        {
            if (y.M[0][j]==0 && y.M[1][j]==0) continue;
            c.M[i][j]=0;
            for (k=0;k<2;k++)
            {
                if (x.M[i][k]==0 || y.M[k][j]==0) continue;
                c.M[i][j]=c.M[i][j]+x.M[i][k]*y.M[k][j];
            }
            c.M[i][j]%=p;
        }
    }
    return c;
}

long long Fpow(int a,int n)
{
    long long ret=1;
    long long A=a;
    while(n)
    {
        if (n & 1)
        {
            ret=(ret*A)%p;
        }
        A=(A*A)%p;
        n>>=1;
    }
    return ret;
}

int main()
{
    int i,j,x1,y1,z1,y2,z2;
    long long q;
    while(1)
    {
        scanf("%d%d%d",&x1,&y1,&z1);
        if (x1==-1 && y1==-1 && z1==-1) break;
        scanf("%d%d",&y2,&z2);
        scanf("%lld",&p);
        q=(Fpow(x1,y1)+z1)%p;
        a.M[0][0]=(q-1+p)%p;
        a.M[0][1]=q;
        a.M[1][0]=1;
        a.M[1][1]=0;
        b.M[0][0]=1;
        b.M[1][0]=0;
        aa=a;
        while(z2)
        {
            if (z2 & 1)
            {
                b=Mul(aa,b);
            }
            aa=Mul(aa,aa);
            z2>>=1;
        }
        for (i=0;i<y2;i++)
        {
            b=Mul(a,b);
            a=Mul(a,a);
        }
        printf("%lld\n",b.M[0][0]);
    }
    return 0;
}



你可能感兴趣的:(hdu3411 Snail Alice)