Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14724 Accepted Submission(s): 5861
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
Author
Teddy
Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
Recommend
lcy
一个简单的01背包问题,WA了3次!!!!!
思维不够严谨,未注意特殊数据!!!! 平时多总结留心!!!!!
特殊数据:背包的价值和体积可能出现0!!!!!
#include<stdio.h>
#define MAXN 1001
int w[MAXN],v[MAXN];
int f[MAXN];
int main(void)
{
int T;
scanf("%d",&T);
while(T--)
{
int N,V,i,j;
scanf("%d%d",&N,&V);
for(i=1;i<=N;i++)
scanf("%d",&v[i]);
for(i=1;i<=N;i++)
{
scanf("%d",&w[i]);
}
for(i=0;i<=V;i++)
f[i]=0;
for(i=1;i<=N;i++)
for(j=V;j>=w[i];j--)
f[j]=f[j]>f[j-w[i]]+v[i]?f[j]:f[j-w[i]]+v[i];
printf("%d\n",f[V]);
}
return 0;
}