poj2723

Get Luffy Out
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6706   Accepted: 2565

Description

Ratish is a young man who always dreams of being a hero. One day his friend Luffy was caught by Pirate Arlong. Ratish set off at once to Arlong's island. When he got there, he found the secret place where his friend was kept, but he could not go straight in. He saw a large door in front of him and two locks in the door. Beside the large door, he found a strange rock, on which there were some odd words. The sentences were encrypted. But that was easy for Ratish, an amateur cryptographer. After decrypting all the sentences, Ratish knew the following facts:

Behind the large door, there is a nesting prison, which consists of M floors. Each floor except the deepest one has a door leading to the next floor, and there are two locks in each of these doors. Ratish can pass through a door if he opens either of the two locks in it. There are 2N different types of locks in all. The same type of locks may appear in different doors, and a door may have two locks of the same type. There is only one key that can unlock one type of lock, so there are 2N keys for all the 2N types of locks. These 2N keys were divided into N pairs, and once one key in a pair is used, the other key will disappear and never show up again.

Later, Ratish found N pairs of keys under the rock and a piece of paper recording exactly what kinds of locks are in the M doors. But Ratish doesn't know which floor Luffy is held, so he has to open as many doors as possible. Can you help him to choose N keys to open the maximum number of doors?

Input

There are several test cases. Every test case starts with a line containing two positive integers N (1 <= N <= 2 10) and M (1 <= M <= 2 11) separated by a space, the first integer represents the number of types of keys and the second integer represents the number of doors. The 2N keys are numbered 0, 1, 2, ..., 2N - 1. Each of the following N lines contains two different integers, which are the numbers of two keys in a pair. After that, each of the following M lines contains two integers, which are the numbers of two keys corresponding to the two locks in a door. You should note that the doors are given in the same order that Ratish will meet. A test case with N = M = 0 ends the input, and should not be processed.

Output

For each test case, output one line containing an integer, which is the maximum number of doors Ratish can open.

Sample Input

3 6
0 3
1 2
4 5
0 1
0 2
4 1
4 2
3 5
2 2
0 0

Sample Output

4
#include<stdio.h>
#include<iostream>
using namespace std; 
 
#define maxn 3010 
 
int n, m; 
int g[maxn][maxn], ct[maxn], f[maxn]; 
int x[maxn], y[maxn]; 
int prev[maxn], low[maxn], stk[maxn], sc[maxn]; 
int cnt0, ptr, cnt1; 
 
void dfs(int w) 
{ 
    int min(0); 
    prev[w] = cnt0++; 
    low[w] = prev[w]; 
    min = low[w]; 
    stk[ptr++] = w; 
    for (int i = 0; i < ct[w]; i++)//ct[]:邻接接边数量 
    { 
        int t = g[w][i]; 
        if (prev[t] == -1) 
            dfs(t); 
        if (low[t] < min) 
            min = low[t]; 
    } 
    if (min < low[w]) 
    { 
        low[w] = min; 
        return; 
    } 
    do 
    { 
        int v = stk[--ptr]; 
        sc[v] = cnt1; 
        low[v] = maxn; 
    } 
    while (stk[ptr] != w); 
    ++cnt1; 
} 
 
void Tarjan(int N) 
{ 
    cnt0 = cnt1 = ptr = 0; 
    int i; 
    for (i = 0; i < N; ++i) 
        prev[i] = low[i] = -1; 
    for (i = 0; i < N; ++i) 
        if (prev[i] == -1) 
            dfs(i); 
} 
 
int solve() 
{ 
	int i;
    Tarjan(n); 
    for ( i = 0; i < n; i++) 
    { 
        if (sc[i] == sc[f[i]]) 
            return 0; 
    } 
    return 1; 
} 
 
int check(int Mid) 
{ 
	int i;
    for ( i = 0; i < n; i++)//init 
        ct[i] = 0; 
    for ( i = 0; i < Mid; i++) 
    { 
        //ct[i]:记录邻接边的数量 
        g[f[x[i]]][ct[f[x[i]]]++] = y[i];//~xi->y[i] 
        g[f[y[i]]][ct[f[y[i]]]++] = x[i];//~yi->xi 
    } 
    return solve(); 
} 
 
int main() 
{ 
	int i;
    //freopen("t.txt", "r", stdin); 
    while (scanf("%d%d", &n, &m), n | m) 
    { 
        for ( i = 0; i < n; i++) 
        { 
            int p, q ; 
            scanf("%d%d", &p, &q); 
            f[p] = q; 
            f[q] = p; 
        } 
        for ( i = 0; i < m; i++) 
            scanf("%d%d", &x[i], &y[i]); 
        n *= 2; 
        int Min = 0, Max = m + 1;//二分枚举能够上的层数 
        while (Min + 1 < Max) 
        { 
            int Mid = (Min + Max) / 2; 
            if (check(Mid)) 
                Min = Mid; 
            else 
                Max = Mid; 
        } 
        printf("%d\n", Min); 
    } 
    return 0; 
} 


你可能感兴趣的:(poj2723)